Totally lost when compiling

General OpenMP discussion

Totally lost when compiling

Postby etoubes » Sat May 31, 2008 2:32 am

Hi everyone!
I'm new to OpenMP and I'm really lost here... I need to compile a program in OpenMp and the following happens:

I call my make file, that has the following code:
[size=85]CC = ./ompcc
LD = ${CC}
CFLAGS= -Wall -fopenmp -g
PRGS = nbody
OBJS = video.o
LIBS = -lm
all: $(PRGS)
%.o: %.c $(HEADERS)
$(CC) $(CFLAGS) -c $*.c $(INCLUDE) -o $@
$(PRGS): $(OBJS)
$(PRGS): % : %.o
$(CC) $(CFLAGS) -o $@ $< $(OBJS) $(LDFLAGS) $(LIBS)
clean:
-rm -f *.o *~ $(PRGS)
[/size]

I get the following error:
./ompcc -Wall -fopenmp -g -c nbody.c -o nbody.o
make: ./ompcc: No se encontró el programa
make: *** [nbody.o] Error 127

What is going on?! I have to say that my level of C, Unix and OpenMP y very low... because probably this a very obvious error, what I don't know what the heck is tell me.

Thanks in advance!
Enrique
etoubes
 

Re: Totally lost when compiling

Postby ejd » Wed Aug 13, 2008 11:35 pm

Sorry - my Spanish is very bad - but I believe "No se encontró el programa" translates to "Program not found". My "make" is almost as bad, but it would seem as though make can't find "./ompcc". As specified, it will look for it in the current directory. Check to see where it is actually located.
ejd
 
Posts: 1025
Joined: Wed Jan 16, 2008 7:21 am

Re: Totally lost when compiling

Postby mwolfe » Mon Aug 25, 2008 3:36 pm

It looks like you want to be using gcc. Your makefile is looking for a file or script named 'ompcc' in the current directory. Try replacing with CC=gcc

-mw
mwolfe
 
Posts: 54
Joined: Mon Aug 25, 2008 3:19 pm


Return to Using OpenMP

Who is online

Users browsing this forum: Exabot [Bot], Yahoo [Bot] and 12 guests